Matcher stall

Incident Report for Polymarket US System Status

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 20:15 EDT

Monitoring

The matcher is recovering
Posted Jul 14, 2026 - 20:13 EDT

Investigating

We are tracking a stall in our matcher, the matcher should recover shortly
Posted Jul 14, 2026 - 20:11 EDT
This incident affected: Polymarket US Exchange.