Position updates are delayed

Incident Report for Polymarket US System Status

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 17:31 EDT

Monitoring

We have rolled out a patch and should see recovery in 5mins.
Posted Jul 20, 2026 - 17:29 EDT

Update

Position server is still having issues, we're working with our vendor to generate a new patch to unblock us.
Posted Jul 20, 2026 - 17:11 EDT

Identified

we have restarted the positions server and waiting for it to re-hydrate
Posted Jul 20, 2026 - 15:59 EDT

Investigating

We are currently investigating this issue.
Posted Jul 20, 2026 - 15:49 EDT
This incident affected: Polymarket US Exchange.