High latency on balance ledger API calls

Incident Report for Polymarket US System Status

Resolved

The issue has been resolved.
Posted Sep 11, 2026 - 06:03 EDT

Investigating

We are investingating high latency on the /v1/funding/balance-ledger endpoint
Posted Sep 10, 2026 - 11:35 EDT
This incident affected: [Production] Polymarket US Exchange.